ccie voice lab workbook-cisco questions

This web site is about ccie voice lab workbook, cisco questions, cisco networking academy ccnp, cisco networking academy ccnp, cisco ccie voice lab.-All the news about ccie voice lab workbook

Monday, May 19, 2008

A cisco ccnp bootcamp Artilce for Your Viewing

News about cisco ccnp bootcamp

Gatekeeper trunk redundancy

Wed, 02 Aug 2006 18:56:42 +0000
If you have two gatekeeper trunks, one in a G711 region and the other in a G729 region and you setup the Route list with G711 as the first priority and G729 as the second priority and the gatekeeper does not have enough bandwidth to process a G711 call, then it will fallback and use ...]

span>MultiPoint Bridging over Ethernet (MPBE)
The MultiPoint Bridging over Ethernet (MPBE) on 7600-ESM-2X10GE and 7600-ESM-20X1GE feature provides Ethernet LAN switching with MAC learning, local VLAN significance, and full QoS support. MPBE also provides Layer 2 switchport-like features without the full switchport implementation.

Both features are supported only through Ethernet Virtual Connection Services (EVCS) service instances.

EVCS uses the concepts of EVCs (Ethernet virtual circuits) and service instances. An EVC is an end-to-end representation of a single instance of a Layer 2 service being offered by a provider to a customer. It embodies the different parameters on which the service is being offered. A service instance is the instantiation of an EVC on a given port on a given router.


This was my test setup regarding the ES20 :

CISCO7609
WS-SUP720-3BXL
7600-ES20-GE3C
IOS 12.2.33SRC

I also used 2 6500s (with 6724-SFP cards) and 2 routers (7200s), creating an ethernet-only network like the following:

Router-1 <===> 6500-1 <===> 7609 <===> 6500-2 <===> Router-2

My objectives were the following:

1) Start from single-tag ip termination (Router-1) and end to double-tag ip termination (Router-2)
2) Translate an outer vlan to a new one (2999 => 3999) while moving from 6500-1 to Router-2, leaving the inner vlans unchanged and vice versa
3) Terminate an outer-vlan/inner-vlan pair (2999/103) locally on the 7609
4) Apply some egress QoS (shaping, LLQ) on the above 2 vlans on the 7609

Router-1 <===> 6500-1
Router-1 interface is an ethernet interface with many ip subinterfaces


interface GigabitEthernet0/2.101
description ** 6500-1 - vlan 101 **
encapsulation dot1Q 101
ip address 10.101.0.1 255.255.255.252
!
interface GigabitEthernet0/2.102
description ** 6500-1 - vlan 102 **
encapsulation dot1Q 102
ip address 10.102.0.1 255.255.255.252
!
interface GigabitEthernet0/2.103
description ** 6500-1 - vlan 103 **
encapsulation dot1Q 103
ip address 10.103.0.1 255.255.255.252

6500-1 interface is a dot1q-tunnel (double-tagging all incoming frames)

interface GigabitEthernet3/9
description ** Router-1 **
switchport
switchport access vlan 2999
switchport mode dot1q-tunnel
mtu 9216
mls qos trust cos
mls qos cos-mutation COS-TUNNEL-MAP
spanning-tree bpdufilter enable


6500-1 <===> 7609
6500-1 interface is a trunk (allowing only the original outer vlan)

interface GigabitEthernet3/10
description ** 7609 Gi5/0/0 **
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2999
switchport mode trunk
switchport nonegotiate
mtu 9216
mls qos trust cos
mls qos cos-mutation COS-TUNNEL-MAP
spanning-tree bpdufilter enable

7609 interface includes a service instance for the outer vlan translation

interface GigabitEthernet5/0/0
mtu 9216
service instance 2999 ethernet
encapsulation dot1q 2999
rewrite ingress tag translate 1-to-1 dot1q 3999 symmetric

The number 2999, which is used for defining the service instance, can be whatever you like; it doesn't have to be the same as the vlan number. I just used the same number for easiness.
The "encapsulation dot1q 2999" command defines the ingress match criteria for this service instance.
The "rewrite ingress tag translate 1-to-1 dot1q 3999 symmetric" command defines a 1-to-1 translation of the ingress matched vlan (2999) to 3999 and the opposite ("symmetric").
Generally, the service instance is "equivalent" to a trunk port.

7609
The 7609 does mainly two things:

Outer vlan translation (see above) and egress shaping

class-map match-all TRAFFIC1
match cos 6 7
!
policy-map TRAFFIC1
class TRAFFIC1
shape average 128000
class class-default
shape average 10000000
!
interface GigabitEthernet5/0/0
mls qos trust cos
service instance 2999 ethernet
service-policy output TRAFFIC1
!
connect EVC1 GigabitEthernet5/0/0 2999 GigabitEthernet5/0/1 3999

The "connect EVC1..." command creates the evc that connects the 2 service instances of the 2 interfaces of the 7609.

IP Q-in-Q termination for a specific outer-vlan/inner-vlan pair and egress LLQ/policing

class-map match-all TRAFFIC2
match cos 3 5
!
policy-map TRAFFIC2
class TRAFFIC2
police 5000000
priority
class class-default
shape average 1000000
!
interface GigabitEthernet5/0/0.2999103
description ** local termination - vlan 2999/103 **
encapsulation dot1Q 2999 second-dot1q 103
ip address 10.103.0.2 255.255.255.252
service-policy output TRAFFIC2

Policing must be used together with priority for LLQ.

7609 <===> 6500-2
7609 interface includes a service instance for the outer vlan translation

interface GigabitEthernet5/0/1
description ** 6500-2 **
mls qos trust cos
service instance 3999 ethernet
encapsulation dot1q 3999
rewrite ingress tag translate 1-to-1 dot1q 2999 symmetric

6500-2 interface is a trunk (allowing only the translated outer vlan)

interface GigabitEthernet3/11
description ** 7609 Gi5/0/1 **
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3999
switchport mode trunk
switchport nonegotiate
mtu 9216
mls qos trust cos
mls qos cos-mutation COS-TUNNEL-MAP
spanning-tree bpdufilter enable


6500-2 <===> Router-2
6500-2 interface is a trunk (allowing only the translated outer vlan)

interface GigabitEthernet3/12
description ** Router-2 **
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 3999
switchport mode trunk
switchport nonegotiate
mtu 9216
mls qos trust cos
mls qos cos-mutation COS-TUNNEL-MAP
spanning-tree bpdufilter enable

Router-2 interface is an ethernet interface with the remaining IP Q-in-Q subinterfaces

interface GigabitEthernet0/2.3999101
description ** 6500-2 - vlan 3999/101 **
encapsulation dot1Q 3999 second-dot1q 101
ip address 10.101.0.2 255.255.255.252
!
interface GigabitEthernet0/2.3999102
description ** 6500-2 - vlan 3999/102 **
encapsulation dot1Q 3999 second-dot1q 102
ip address 10.102.0.2 255.255.255.252



Btw, the CCO configuration page about ES20 must be one of the worst ever written. Many configuration examples are wrong (they probably haven't even tried them), while some other are missing explanations.Tassos (CCIE™ No. 19858)http://www.blogger.com/profile/04512662084752743003noreply@blogger.comtag:blogger.com,1999:blog-4567382598724166625.post-4719139877717836832008-02-10T13:18:00.000+02:002008-02-10T18:14:42.043+02:00show parser dump - full CLI syntax at your handsTo display the CLI syntax options for all command modes or for a specified command mode, you can use the show parser dump command in privileged EXEC mode.

This command was developed to allow the exploration of the CLI command syntax without requiring the user to actually enter a specific mode and use the ? command line help.

Examples:

The following command will display all the commands that can by entered under "map-class" config mode and contain the "frame-relay" word:


router#show parser dump map-class | inc frame-relay


The following command will display all the commands that can be entered under the "route-map" config mode and contain the "match" word:


router#show parser dump route-map | inc match


The following will display all commands (config & exec) that contain the word "igmp" :


router#show parser dump all | inc igmp


So, if you don't remember a specific command, but you know a keyword that might be included in it, you can use the "show parser dump" commands to help you find all possible syntaxes.

The number that you seen in front of each command syntax is the privilege level required in order to execute that command.

You can also use the "extend" keyword at the end in order to display more detailed keyword and argument descriptions:


router#sh parser dump sla-monitor extend
Mode Name :sla-monitor
15 type udpEcho dest-ipaddr dest-port <1-65535> source-ipaddr
type : Type of entry
udpEcho : UDP Echo Operation
dest-ipaddr : Destination address
: IP address or hostname
dest-port : Destination Port
<1-65535> : Port Number
source-ipaddr : Source address
: IP address or hostname

15 type udpEcho dest-ipaddr dest-port <1-65535> source-port <1-65535>
type : Type of entry
udpEcho : UDP Echo Operation
dest-ipaddr : Destination address
: IP address or hostname
dest-port : Destination Port
<1-65535> : Port Number
source-port : Source Port
<1-65535> : Port Number


Caution
Use caution when entering this command with the all keyword. A large amount of output can be generated by this command, which may easily exceed buffer or system memory on smaller platforms. Also, some configuration modes have hundreds of valid commands. For large dumps, use of the redirection to a file using the | redirect URL syntax at the end of the command is highly recommended.
Tassos (CCIE™ No. 19858)http://www.blogger.com/profile/04512662084752743003noreply@blogger.com
tag:blogger.com,1999:blog-4567382598724166625.post-54968285944621158092008-02-06T15:29:00.000+02:002008-02-10T14:48:43.888+02:00CCIE practice - My dynamips environmentThis is the PC i used during my practice:

Abit IP35Pro
Core2Duo E6550 (@2.66)
2 GB DDR2 RAM
320GB HD
Windows XP & Ubuntu

I started using WindowsXP, but soon i found out that i couldn't run concurrently >10 routers (i didn't insist too much on trying this). So i switched to Ubuntu, where after 1 week of trial & error, i managed to create my home environment and then run the sample lab that is provided free at IE's site. You can find more information on a previous post of mine about this setup.

Afterwards, i started creating mini labs on this setup, based on the topology of IE's sample lab, "stealing" ideas from the 2 CCIE Practical Studies books and adapting them to a specific physical topology. I started using 3640s as routers and switches (using 12.3(14)T7) but i had a lot of issues with spanning-tree & transparent vtp (it was like spanning tree was getting stuck). So i decided to use 3725s as switches, 3640s as routers and move both routers and switches to latest 12.4 IOS (12.4(17a) at that time).

Although everything was working fine in Ubuntu, i had to switch to Windows quite often in order to check some other material i had there, especially my email (although i could read my new emails from inside Ubuntu, i couldn't read the old ones). Also, i was experiencing strange crashes once in a while in Ubuntu, when restarting dynagen. So i decided to give it one more try and transfer the dynamips/dynagen setup to Windows again.

I had already found the ideal idlepc values for my routers' ios on Ubuntu, so i was going to use the same on Windows. The biggest difference between Ubuntu & Windows, was that i had to use the sparsemem option in dynagen on Windows (only for routers) in order to decrease memory usage, but even after that, Ubuntu was still using less memory. Also, cpu usage was a little bit higher in Windows, but as long as it stayed below 15%, is wasn't a problem. Having full configurations on all 13 routers/switches kept the cpu around 40% busy, which was fine by me (in Ubuntu it was under 20%). At the same time, memory usage was around 1.4GB on Windows and under 1 GB in Ubuntu.

I used 2 dynamips processes in order to split the memory usage per process (Windows is said to have a problem with this) and i assigned all routers in one process and all switches + bb routers in the other process (pretty much like IE's dynamips setup). Btw, you can find a lot of useful info about dynamips/dynagen in http://7200emu.hacki.at/index.php.

This is the general routers/switches dynagen setup i used on Windows:


3640]]
image = C:\images\c3640-ik9o3s-mz.124-17a.extracted.bin

ram = 128
disk0 = 0
disk1 = 0
idlepc = 0x605a5040
mmap = True
ghostios = True
sparsemem = true

3725]]
image = C:\images\c3725-adventerprisek9-mz.124-17a.extracted.bin

ram = 128
disk0 = 8
disk1 = 0
idlepc = 0x62379ed0
mmap = True
ghostios = True


It took me a while until i was able to initialize the setup for every mini-lab i was having. I was spending around 2 hours in order to prepare my setup for each mini-lab. But, after creating a xls table with the differences between my physical topology and the mini-lab topologies, i managed to bring this time down to 20-30 minutes.

I also used the same topology for all the Mock Labs, which helped me a lot. There were some issues with L2 features not supported by dynamips, but i wasn't worried because i knew most of this stuff. Nevertheless, i had a scrap paper near me where i was taking notes and i also used it for writing down all the config commands i couldn't configure. That way i was able to grade myself in everything, even in things dynamips didn't support.

One thing that i didn't regret of, is that when i was redoing my Mock Labs using dynamips, i did every possible task, even the ones that seemed silly and were repeated quite a few times. There were times that i was thinking how boring is to configure something for nth time, but i knew i had to do it if i wanted to succeed.

Lastly, i had created a pdf file like the following (i created it in Excel, then converted it to PDF and printed it), where for every Mock Lab i was writing the task number, the task points, whether i though i had completed it and some notes about tricky things or things to be looked later.

After finishing each lab, i was comparing my solution to the proctor's one and i was grading myself. Mostly i was giving myself lower grades for all alternative solutions, until i was 100% sure that my solution was correct too. That way, after finishing all Mock Labs, i was able to see in what parts i had repeatedly made mistakes so that i could focus more on these.

My final advice :
Try to be organized! It'll make your preparation much easier.
Try to repeat things! It'll make you exam much easier.

In the meanwhile, i have already decided what exam i'm going to try next, but i won't reveal it until the poll ends. Of course my pre-preparation has already started...

Btw, i 'm also searching for a new job. Last weekend i rewrote my CV (it has been a long time since i had updated it) and i have already found 3 "candidate" companies which seem very interesting. But i won't do anything until the end of this month, because i'm waiting for an offer from my current job.


Tassos (CCIE™ No. 19858)http://www.blogger.com/profile/04512662084752743003noreply@blogger.com
tag:blogger.com,1999:blog-4567382598724166625.post-55379488600543407132008-02-02T16:49:00.013+02:002008-05-12T02:19:19.068+03:00Greek CCIEsI tried to find the 43 Greek CCIEs that are active and this is the list i have come up until now:

4446 Dimitris Kotantoulas (?)
6866 Vassilis Constantopoulos
6981 Nikolaos Apοstolou
Sotiris Spanos
Paraskevas Lykourgiotis
Vicky Fyrigou
7201 Yiannis Theologitis
7394 Elias Aggelidis
7522 Giannis Mouzakis
7676 Theodore Tzevelekis
8512 Giorgos Katsikogiannis
9696 Dionisis Koutsis
9723 Thanos Sioutas
10166 Bill Kaloudis
10721 Yiannis Margaritis
10752 Evangelos Vayias
10823 Chris Zotos
10903 Stathis Atmatzidis
11826 Sotiris Leventis
13419 Mike Mihalas (?)
14922 Spyros Kranis
15010 George Papadimitriou
18448 Katerina Proestaki
19858 Tassos

If anyone knows more info, please help me fill the above list.

Last update : 08-May-2008.
Many thanks to Yiannis (#10721) for providing updated info.
Tassos (CCIE™ No. 19858)http://www.blogger.com/profile/04512662084752743003noreply@blogger.com
tag:blogger.com,1999:blog-4567382598724166625.post-22048802274467415262008-01-28T22:43:00.000+02:002008-02-10T15:36:40.257+02:00CCIE practice - My "scripts"I wouldn't call them scripts. They are just simple commands that help you get quickly the information required.

Maybe you have already seen them around. Some parts are surely not mine. I just found them and adapted them to my needs.

Collection Scripts

Collect the active ip addresses from each router/switch

end

sh ip int br | exc unass

wr


Collect the ip addresses belonging to backbone routers
$INTERFACE is the physical interface where the backbone router is connected
Read your exam for the ip addresses to be tested (used only for IGP routes)

end

sh ip route | inc $INTERFACE


While running the above collection scripts, keep a notepad window open with the following testing scripts into it and fill in the ip addresses that you collect. Using Alt + Left Mouse Button selects a rectangle in SecureCRT, so you can very easily get the ip addresses from the above outputs.

Testing Scripts

Test ip connectivity on each router

end
tclsh


foreach i {
x.x.x.x
y.y.y.y
.......
} { ping $i }


Don't forget to exit from tcl ("tclquit") when finished, because you might have some IOS commands ("set" under route-maps) behave "strangely" inside it.


Test ip connectivity on each switch

conf t

macro name PING
do ping x.x.x.x
do ping y.y.y.y
do ping .......
@

end

After creating the above macro, you only need to run the following each time you want to test

conf t

macro global apply PING


After you finish all testing (and before the lab exam ends), don't forget to remove the macro from the switches.

Removal Scripts

Remove macro from switches

end
sh run | inc macro

conf t

no ...

end

or

conf t

no macro name PING
no macro global desc PING

end


I used all the above scripts in every Mock Lab i had, either online or offline (using Dynamips). During the first ones, i was making a lot of mistakes while configuring them, but after a lot of practice i was able to write all of them into a notepad window in less than 1 minute (do not copy-paste them while practicing; try to write them down every time).

Collection of ip addresses shouldn't take you more than 2-3 minutes, especially if you use my 2 desktop environments. The whole scripting thing should take you less than 4 minutes, plus 1 minute for running the 2 testing scripts simultaneously on all routers and then on all switches (you just copy-paste the testing scripts on all the windows and watch the outputs). Of course, if an ip address is unreachable, you'll get an extra delay, so try to remove from the scripts all ip addresses that do not need reachability; "DO NO NEED" is always according to the exam instructions. If the ip address needs reachability, you'd better check your configuration.

Finally, note that the CCIE Lab is not about scripting. You don't want to spend your time configuring (and possibly trying to remember) complex scripts. I have seen a lot of super-duper scripts that could even "make you a coffee" (that's a greek phrase), but if you don't know the stuff you're being tested, they aren't going to help you. They might even slow you down.

One of your tasks when being at the CCIE Lab is to be as simple and as fast as possible. Your main focus should be on the lab tasks and not on any extra scripts that are there to help you. Use the scripts in order to verify quickly some parts of the required tasks, but do not rely on them for passing the lab.

Scripts can make your lab "easier" in regards to time management. That's their only role.
Tassos (CCIE™ No. 19858)http://www.blogger.com/profile/04512662084752743003noreply@blogger.com
tag:blogger.com,1999:blog-4567382598724166625.post-46513753408607893992008-01-28T10:33:00.000+02:002008-01-28T22:38:45.023+02:00CCIE practice - My desktop environmentThese are the two desktop environments i was using during my practice. These are also the ones i used in the CCIE Lab. The only difference is that i used Putty during my practice (it's the lightest telnet client and it's free) vs SecureCRT in the CCIE Lab. But since i knew i was going to use SecureCRT in the lab, i spent 1 hour on practicing with it, just the day before my flight to Brussels.

Desktop 1 : Routers R1 - R6


Desktop 2 : Switches SW1 - SW4

According to each lab task, you either minimize or restore the appropriate windows.

That way you can copy-paste (left=select/copy, middle/right=paste) between windows very easily/quickly and most importantly you can watch half of your equipment all the time (R5,R6 are half covered, so you need to click on them in order to bring them full in front). i.e. when you change something on a router/switch, you can see immediately if there is a log produced on another router/switch. You cannot do this when using the terminal server.

All the windows have the equivalent router/switch name as their title, so it's very easy to select which one to have on your desktop every time. In a screen of 1280x1024, i used 82x28 (columns x rows) as the size of the windows (you can start from 80x25 depending on your desktop resolution and font used) and "courier-new 9" was the font and font-size.

I also used black background and white foreground (default in Putty, had to reverse in SecureCRT), because those seemed the most relaxing colors. If you have to look at these windows for 8+ hours, you need to take care of everything, even your own eyes. You need to have the whole environment cooperate with you, not fight against you.
Tassos (CCIE™ No. 19858)http://www.blogger.com/profile/04512662084752743003noreply@blogger.com
tag:blogger.com,1999:blog-4567382598724166625.post-84467681329796881032008-01-26T13:31:00.000+02:002008-01-26T14:30:34.067+02:00CCIE Program Offers Weekend Lab ExamsAlthough it's old news, i just found out the following:

In an attempt to significantly reduce the wait time for a lab appointment, the CCIE team is offering weekend lab exams in Routing and Switching. The following dates and locations are the first to open.

i am using visual C++ 6.o

Mon, 19 May 2008 04:08:23 GMT
#include "Student.h"
#include
#include
#include
using namespace std;
Student::Student()
{
name=" ";
surname="";
assignment1Mark=0;

We had put all our efforts to produce some respectable reading matter on cisco ccnp bootcamp. We sure do wish it's respectable enough for you.
#



cisco ccnp bootcamp Items For Viewing


Abacus24-7 Printer Ink, Cables, Batteries & Memory
Hot Hard Drive Deals at CompUSA Today!


ccie
ccie 350 001
ccie assessor lab
| |

Labels: